As I'm working on an Android project, I was trying to build a Google sample and got a weird error message that the IDE couldn't auto-fix:

The project is using an unsupported version of the Android Gradle plugin.

For anyone else searching for this, then answer turned out to be that this version (0.8.9) of Android Studio use a newer version than the one specified in the build.gradle file.  Updating from 0.9.+ to 0.12.+ fixed the issue for me.

Seems like this will be an on-going problem with using Android Studio unless Google continuously goes back and updates their sample code, which seems unlikely.

Hope this helps!